Why is the gnome gone?

So, zunächst einmal ein kleines Video:

Ein alter Grundsatz lautet: Linux verzeiht nicht. Einmal rm -rf / mit sudo und tschüss.
Im Grundsatz lässt sich Linux aber als sehr vertrauenswürdig einstufen. Leider Gottes ist Linux aber nicht Gott und macht manchmal auch Fehler.
Ich finds ja super, dass mir apt-get sagt, wenn Pakete nicht mehr gebraucht werden, und diese auch gleich entfernen will. Wenn bei einem autoremove aber einfach mal so 900MB frei werden, sollte man doch stutzig werden. Aber zu später Stunde kann man das auch mal übersehen und drückt vorschnell das j. Einmal lesen, und das hätte mich nachdenklich machen sollen:

fire - kill0rz.com

python3-pyatspi:amd64 (2.14.0+dfsg-1), bogofilter-bdb:amd64 (1.2.4+dfsg1-3+b1), telepathy-haze:amd64 (0.8.0-2), libboost-system1.55.0:amd64 (1.55.0+dfsg-3), libwinpr-thread0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), telepathy-idle:amd64 (0.2.0-2), libebook-contacts-1.2-0:amd64 (3.12.9~git20141128.5242b0-2+deb8u2), libspice-client-gtk-3.0-4:amd64 (0.25-1+b1), libsgutils2-2:amd64 (1.39-1), gnustep-common:amd64 (2.6.6-3), fonts-cantarell:amd64 (0.0.16-1), libmspub-0.1-1:amd64 (0.1.1-2), gir1.2-gdm3:amd64 (3.14.1-7), libreoffice:amd64 (4.3.3-2+deb8u1), libsofia-sip-ua-glib3:amd64 (1.12.11+20110422.1-2), rhythmbox-plugins:amd64 (3.1-1), empathy-common:amd64 (3.12.7-1), freerdp-x11:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), empathy:amd64 (3.12.7-1), libchamplain-gtk-0.12-0:amd64 (0.12.9-1), lightsoff:amd64 (3.14.1-1), python-wnck:amd64 (2.32.0+dfsg-3), argyll:amd64 (1.6.3-4), libqt4-xml:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), iagno:amd64 (3.14.1-2), python3-markupsafe:amd64 (0.23-1+b1), caribou:amd64 (0.4.15-1), libfreerdp-client1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), libwinpr-utils0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), xbrlapi:amd64 (5.2~20141018-5), libidl0:amd64 (0.8.14-0.4+b1), libfreerdp-core1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), gir1.2-zpj-0.0:amd64 (0.0.3-1+b1), xboard:amd64 (4.8.0-2), zeitgeist-core:amd64 (0.9.14-2.2), dleyna-renderer:amd64 (0.4.0-1), qtchooser:amd64 (47-gd2b7997-2), gir1.2-wnck-3.0:amd64 (3.4.9-3), libwinpr-synch0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), swell-foop:amd64 (3.14.0-1), gnustep-base-common:amd64 (1.24.7-1), gnome-games:amd64 (3.14+3), gnome-orca:amd64 (3.14.0-4), libgfbgraph-0.2-0:amd64 (0.2.2-1), gnome-online-miners:amd64 (3.14.0-2), libwinpr-pool0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), libusbredirparser1:amd64 (0.7-1), telepathy-salut:amd64 (0.8.1-4), libvisio-0.1-1:amd64 (0.1.0-2), libgtk-vnc-2.0-0:amd64 (0.5.3-1.3), libebackend-1.2-7:amd64 (3.12.9~git20141128.5242b0-2+deb8u2), gnome-logs:amd64 (3.14.2-1), telepathy-gabble:amd64 (0.18.3-1+b1), gir1.2-gnomedesktop-3.0:amd64 (3.14.1-1), simple-scan:amd64 (3.14.0-1), bogofilter:amd64 (1.2.4+dfsg1-3), qdbus:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), libwinpr-handle0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), gir1.2-grilo-0.2:amd64 (0.2.11-2), libwinpr-crt0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), libqtcore4:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), hyphen-en-us:amd64 (2.8.8-1), libreoffice-impress:amd64 (4.3.3-2+deb8u1), libfreerdp-cache1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), libwinpr-interlocked0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), libreoffice-avmedia-backend-gstreamer:amd64 (4.3.3-2+deb8u1), libqt4-dbus:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), gnome-disk-utility:amd64 (3.12.1-1+b1), espeak-data:amd64 (1.48.04+dfsg-1), gir1.2-secret-1:amd64 (0.18-1+b1), telepathy-mission-control-5:amd64 (5.16.3-1), gir1.2-gtop-2.0:amd64 (2.28.5-2+b1), gir1.2-ibus-1.0:amd64 (1.5.9-1), gedit-common:amd64 (3.14.0-3), iputils-tracepath:amd64 (20121221-5+b2), libevolution:amd64 (3.12.9~git20141130.241663-1+b1), python3-gi-cairo:amd64 (3.14.0-1), gnome-getting-started-docs:amd64 (3.14.1-1), gnome-tetravex:amd64 (3.14.0-1), gnome-backgrounds:amd64 (3.14.1-1), gstreamer1.0-nice:amd64 (0.1.7-1), libreoffice-draw:amd64 (4.3.3-2+deb8u1), p7zip-full:amd64 (9.20.1~dfsg.1-4.1), tali:amd64 (3.14.0-1), libfolks25:amd64 (0.10.0-1), gir1.2-gkbd-3.0:amd64 (3.6.0-1), python3-brlapi:amd64 (5.2~20141018-5), coinor-libcbc3:amd64 (2.8.12-1), gnome-calculator:amd64 (3.14.1-1), gedit-plugins:amd64 (3.14.0-2), gir1.2-tracker-1.0:amd64 (1.2.4-2), quadrapassel:amd64 (3.14.0-1), libgdict-1.0-6:amd64 (3.14.1-1), libsonic0:amd64 (0.1.17-1.1), gnuchess-book:amd64 (1.02-1), libreoffice-gnome:amd64 (4.3.3-2+deb8u1), telepathy-logger:amd64 (0.8.1-1), lp-solve:amd64 (5.5.0.13-7+b1), gir1.2-vte-2.91:amd64 (0.38.1-2), libgdm1:amd64 (3.14.1-7), hamster-applet:amd64 (2.91.3+git20120514.b9fec3e1-1), python-pyorbit:amd64 (2.24.0-7), libfreerdp-codec1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), libwinpr-input0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), liblinear1:amd64 (1.8+dfsg-4), liblouis-data:amd64 (2.5.3-3), minissdpd:amd64 (1.2.20130907-3), libfreerdp-gdi1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), unoconv:amd64 (0.6-6), coinor-libcoinutils3:amd64 (2.9.15-3), gnome-shell-common:amd64 (3.14.4-1~deb8u1), libprotobuf9:amd64 (2.6.1-1), libavahi-ui-gtk3-0:amd64 (0.6.31-5), unar:amd64 (1.8.1-3+b1), gnome-photos:amd64 (3.14.2-1), gir1.2-git2-glib-1.0:amd64 (0.0.22-1), libmission-control-plugins0:amd64 (5.16.3-1), libqqwing2:amd64 (1.3.2-1), hoichess:amd64 (0.10.3-6.1), gnome-sound-recorder:amd64 (3.14.0.1-1), nmap:amd64 (6.47-3+b1), polari:amd64 (3.14.1-1), gucharmap:amd64 (3.14.1-1), libwinpr-heap0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), libfarstream-0.2-2:amd64 (0.2.4-1), libobjc4:amd64 (4.9.2-10), libcaribou0:amd64 (0.4.15-1), fonts-sil-gentium:amd64 (1.02-13), gir1.2-gucharmap-2.90:amd64 (3.14.1-1), rhythmbox-data:amd64 (3.1-1), p11-kit-modules:amd64 (0.20.7-1), hitori:amd64 (3.14.0.1-1), libwinpr-rpc0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), gir1.2-goa-1.0:amd64 (3.14.2-1), libtelepathy-logger3:amd64 (0.8.1-1), libytnef0:amd64 (1.5-6), rhythmbox-plugin-cdrecorder:amd64 (3.1-1), libcaribou-gtk3-module:amd64 (0.4.15-1), libgpod4:amd64 (0.8.3-1.1+b1), libpst4:amd64 (0.6.59-1), libbrlapi0.6:amd64 (5.2~20141018-5), python-gnome2:amd64 (2.28.1+dfsg-1.1), libwinpr-library0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), gir1.2-polkit-1.0:amd64 (0.105-8), gtk2-engines:amd64 (2.20.2-3), gir1.2-gcr-3:amd64 (3.14.0-2), gir1.2-telepathyglib-0.12:amd64 (0.24.1-1), liblouis2:amd64 (2.5.3-3), libwnck-common:amd64 (2.30.7-2), coinor-libcgl1:amd64 (0.58.9-1), python3-cairo:amd64 (1.10.0+dfsg-4+b1), libedata-book-1.2-20:amd64 (3.12.9~git20141128.5242b0-2+deb8u2), libgtkspell3-3-0:amd64 (3.0.6-1), gnome-chess:amd64 (3.14.0-1), baobab:amd64 (3.14.1-1), gnome-video-effects:amd64 (0.4.1-2), libdotconf0:amd64 (1.3-0.2), libfreerdp-locale1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), gnome-sudoku:amd64 (3.14.1-1), gir1.2-xkl-1.0:amd64 (5.2.1-1), gir1.2-nmgtk-1.0:amd64 (0.9.10.0-2), libfreerdp-plugins-standard:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), gvfs-fuse:amd64 (1.22.2-1), libsvm-tools:amd64 (3.12-1), vino:amd64 (3.14.0-2+b1), cheese:amd64 (3.14.1-2), libfreerdp-primitives1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), gir1.2-caribou-1.0:amd64 (0.4.15-1), python-pyatspi:amd64 (2.14.0+dfsg-1), sound-juicer:amd64 (3.14.0-1+b1), gnome-tweak-tool:amd64 (3.14.2-2), libreoffice-report-builder-bin:amd64 (4.3.3-2+deb8u1), guile-2.0-libs:amd64 (2.0.11+1-9), gir1.2-mutter-3.0:amd64 (3.14.4-1~deb8u1), gnome-dictionary:amd64 (3.14.1-1), libgit2-glib-1.0-0:amd64 (0.0.22-1), libwinpr-registry0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), coinor-libclp1:amd64 (1.15.10-1), dconf-editor:amd64 (0.22.0-1), qtcore4-l10n:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), libreoffice-help-en-us:amd64 (4.3.3-2+deb8u1), gnome-clocks:amd64 (3.14.1-1), gir1.2-atspi-2.0:amd64 (2.14.0-1), libqtdbus4:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), gir1.2-gtkchamplain-0.12:amd64 (0.12.9-1), gcr:amd64 (3.14.0-2), rhythmbox:amd64 (3.1-1), libgtkhtml-4.0-common:amd64 (4.8.5-1), caribou-antler:amd64 (0.4.15-1), gir1.2-gdata-0.0:amd64 (0.16.1-1), libwinpr-sspi0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), libzapojit-0.0-0:amd64 (0.0.3-1+b1), fonts-sil-gentium-basic:amd64 (1.1-7), libgvnc-1.0-0:amd64 (0.5.3-1.3), gir1.2-upowerglib-1.0:amd64 (0.99.1-3.2), python3-speechd:amd64 (0.8-7), gnome-nettool:amd64 (3.8.1-1), speech-dispatcher-audio-plugins:amd64 (0.8-7), libnatpmp1:amd64 (20110808-3), coinor-libosi1:amd64 (0.106.9-1), libboost-thread1.55.0:amd64 (1.55.0+dfsg-3), coinor-libcoinmp1:amd64 (1.7.6+dfsg1-1), libdee-1.0-4:amd64 (1.0.10-3.1), bijiben:amd64 (3.14.2-1+b1), libgtkhtml-editor-4.0-0:amd64 (4.8.5-1), gnome-music:amd64 (3.14.1-1), libfolks-telepathy25:amd64 (0.10.0-1), gnome-documents:amd64 (3.14.2-1), finger:amd64 (0.17-15), vinagre:amd64 (3.14.1-1), fairymax:amd64 (4.8v-1), python-gconf:amd64 (2.28.1+dfsg-1.1), libsofia-sip-ua0:amd64 (1.12.11+20110422.1-2), libfreerdp-rail1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), gnome-screenshot:amd64 (3.14.0-1), libtelepathy-farstream3:amd64 (0.6.2-1), dconf-cli:amd64 (0.22.0-1), gnome-font-viewer:amd64 (3.14.0-2), libwnck22:amd64 (2.30.7-2), libdiscid0:amd64 (0.6.1-3), libetonyek-0.1-1:amd64 (0.1.1-2), libreoffice-gtk:amd64 (4.3.3-2+deb8u1), gnome-color-manager:amd64 (3.14.1-1), bogofilter-common:amd64 (1.2.4+dfsg1-3), libfreerdp-common1.1.0:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), gjs:amd64 (1.42.0-1), gir1.2-rest-0.7:amd64 (0.7.92-3), gnome-nibbles:amd64 (3.14.1-1), libfreerdp-crypto1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), gnuchess:amd64 (6.1.2-1), gedit:amd64 (3.14.0-3), libgpod-common:amd64 (0.8.3-1.1+b1), libzeitgeist-2.0-0:amd64 (0.9.14-2.2), libcaribou-gtk-module:amd64 (0.4.15-1), libebook-1.2-14:amd64 (3.12.9~git20141128.5242b0-2+deb8u2), libgnustep-base1.24:amd64 (1.24.7-1), gnome-mahjongg:amd64 (3.14.1-1), libgtkhtml-4.0-0:amd64 (4.8.5-1), libwinpr-path0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), libwinpr-dsparse0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), python3-louis:amd64 (2.5.3-3), transmission-gtk:amd64 (2.84-0.2), gir1.2-gdesktopenums-3.0:amd64 (3.14.1-1), qt-at-spi:amd64 (0.3.1-5), gir1.2-accountsservice-1.0:amd64 (0.6.37-3+b1), python3-xdg:amd64 (0.25-4), libcdr-0.1-1:amd64 (0.1.0-3), five-or-more:amd64 (3.14.1-1), libchamplain-0.12-0:amd64 (0.12.9-1), gir1.2-gnomebluetooth-1.0:amd64 (3.14.0-2), libwinpr-sysinfo0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), libatk-adaptor:amd64 (2.14.0-2), gir1.2-gck-1:amd64 (3.14.0-2), libespeak1:amd64 (1.48.04+dfsg-1), xdg-user-dirs-gtk:amd64 (0.10-1), argyll-ref:amd64 (1.6.3-4), gir1.2-telepathylogger-0.2:amd64 (0.8.1-1), mythes-en-us:amd64 (3.3.0-4), libwinpr-environment0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), libgit2-21:amd64 (0.21.1-3), python3-mako:amd64 (1.0.0+dfsg-0.1), libusbredirhost1:amd64 (0.7-1), gir1.2-geocodeglib-1.0:amd64 (3.14.0-1), dconf-tools:amd64 (0.22.0-1), gnome-system-log:amd64 (3.9.90-2), gir1.2-mediaart-1.0:amd64 (0.7.0-2), liborcus-0.8-0:amd64 (0.7.0+dfsg-9), media-player-info:amd64 (22-2), transmission-common:amd64 (2.84-0.2), gir1.2-networkmanager-1.0:amd64 (0.9.10.0-7), gir1.2-rb-3.0:amd64 (3.1-1), libspice-client-glib-2.0-8:amd64 (0.25-1+b1), libcaribou-common:amd64 (0.4.15-1), libqtgui4:amd64 (4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1), libgdict-common:amd64 (3.14.1-1), gnome-klotski:amd64 (3.14.1-1), librhythmbox-core8:amd64 (3.1-1), file-roller:amd64 (3.14.1-1), folks-common:amd64 (0.10.0-1), libfreerdp-utils1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), gir1.2-champlain-0.12:amd64 (0.12.9-1), libphonenumber6:amd64 (6.3~svn698-3+b1), libedata-cal-1.2-23:amd64 (3.12.9~git20141128.5242b0-2+deb8u2), spice-client-glib-usb-acl-helper:amd64 (0.25-1+b1), telepathy-rakia:amd64 (0.8.0-3), gnustep-base-runtime:amd64 (1.24.7-1), sound-theme-freedesktop:amd64 (0.8-1), gir1.2-zeitgeist-2.0:amd64 (0.9.14-2.2), libspeechd2:amd64 (0.8-7), libfreehand-0.1-1:amd64 (0.1.0-2), liborbit2:amd64 (2.14.19-0.3), libwinpr-file0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), nautilus-sendto:amd64 (3.8.2-1), four-in-a-row:amd64 (3.14.1-1), aisleriot:amd64 (3.14.1-1), libreoffice-calc:amd64 (4.3.3-2+deb8u1), libwinpr-crypto0.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), liblinear-tools:amd64 (1.8+dfsg-4), libreoffice-evolution:amd64 (4.3.3-2+deb8u1), speech-dispatcher:amd64 (0.8-7), libgail-common:amd64 (2.24.25-3), libminiupnpc10:amd64 (1.9.20140610-2), libxfreerdp-client1.1:amd64 (1.1.0~git20140921.1.440916e+dfsg1-4), gnome-maps:amd64 (3.14.1.2-1), gnome-robots:amd64 (3.14.1-1), ndiff:amd64 (6.47-3), gnome-mines:amd64 (3.14.1-2)

Ich hab also einfach mal meine Desktop-Umgebung entfernt, warum auch nicht 😀
Also staunte ich nach nem Reboot nicht schlecht, als da nur noch ein Kursor blinkte 😀

Good thing habe ich ein zweites Debian installiert. Also das hochgefahren, das andere gemounted und mir die Logs angeguckt. Zack, wach als ich den Block da oben gesehen habe, Facepalm. xD

Meine Lösungsidee war recht einfach: Du weißt, was du deinstalliert hast, also installiere es einfach wieder. Du Trottel.
Nun tippe ich das ja nicht ab 😀 Schnell ne php zusammengebastelt, die mir das ganze in ein kosolenkonformes Format bringt und in eine Datei getee’t:

fire - kill0rz.com
<?php

$array = file("aptpacks.txt");
$array = explode(",",$array['0']);
echo "apt-get install ";
foreach($array as $a){
	if(str_replace("(","",$a) != $a){
		//( ist drin
		$wheretocut = strpos($a,"(");
		$tmp = substr($a,0,$wheretocut);
	}else $tmp = $a;
	echo trim($tmp)." ";
}

Quick&Dirty, aber funktioniert.
Nun musste ich das ganze also nur noch kopieren und einfügen. Macht sich aber schlecht, wenn man keinen Mauszeiger hat 😉
Also einfach gepipet: $ cat file.txt | xargs apt-get install
Blöd nur, dass Ich ja noch auf Enter drücken muss zum bestätigen. Aber weil Linux ja so geil ist, kann man das einfach übergehen:
$ cat file.txt | xargs apt-get -q -y install
900MB installiert und noch ein apt-get install gnome hinterher und zack fertig – schon war der Desktop wieder da 🙂
Tja, Linux verzeiht manchmal halt doch 😉

kill0rz

This entry was posted in Betriebssysteme, kill0rz, Linux. Bookmark the permalink.

2 Responses to Why is the gnome gone?

  1. basti_sk says:

    Konsole ging wohl auch gar nicht mehr?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Bitte löse die Rechnung! * Time limit is exhausted. Please reload CAPTCHA.