[WBB2.3.X] Youtube-BB-Code

Huhu!

Ich habe einen einfachen Youtube-BB-Code für das WBB2.3.X erstellt, getestet mit 2.3.6pl2, müsste aber auch in jeder anderen Version funktionieren. Der Code braucht als Parameter die Video-ID und setzt diese in den neuen Embed-Code von Youtube ein.
Anleitung:

ACP –> BB-Code erstellen –>
BBCode Tag:  youtube
wird ersetzt durch:

<iframe width=“560″ height=“315″ src=“//www.youtube.com/embed/{param1}?rel=0″ frameborder=“0″ allowfullscreen></iframe>

Hierbei können natürlich width und height durch eure Werte ersetzt werden.
Beschreibung (für Hilfe):  Es wird der Parameter eingesetzt und bettet damit das Video ein.
Anzahl Parameter:  1
max. Anzahl der Verschachtelung:  1

fire - kill0rz.com

Dann ladet ihr in jedes eurer Design-Verzeichnisse dieses Bild hier:
bbcode_youtubeAls nächstes wieder im ACP –> Templates bearbeiten (vorher Backup durch Exportieren) –> bbcode_buttons
Suche nach 

<img
src=“{$style[‚imagefolder‘]}/bbcode_php.gif“ alt=“{$lang->items[‚LANG_POSTINGS_BBCODE_PHP‘]}“ title=“{$lang->items[‚LANG_POSTINGS_BBCODE_PHP‘]}“ border=“0″ onclick=“bbcode(document.bbform,’PHP‘,“)“ onmouseover=“this.style.cursor=’hand‘;“ />

Füge danach ein: 

<img
src=“{$style[‚imagefolder‘]}/bbcode_youtube.gif“ }“ border=“0″ onclick=“bbcode(document.bbform,’YOUTUBE‘,“)“ onmouseover=“this.style.cursor=’hand‘;“ />

fire - kill0rz.com

Fertig, nun solltet ihr das Symbol in jedem Editor sehen. Die Änderungen an dem Template müssen für jedes Templatepack wiederholt werden, das durch irgendein Design benutzt wird.

Vielleicht bringt es ja dem ein oder anderen etwas 😉
kill0rz

This entry was posted in Allgemein, Hacks & -angriffe, Internet, kill0rz, Optimierung, Scene, self-coded, Server, WBB. Bookmark the permalink.

4 Responses to [WBB2.3.X] Youtube-BB-Code

  1. Ronny says:

    habs deinen BB Code im wbb2.6.3 eingebaut, läuft leider nicht. Das Bild wird nicht angezeigt und anklickbar ist es auch nicht. 🙁 schade. Kannst du das einmal Überprüfen ?

    • kill0rz says:

      Hallo Ronny,

      ich habe gerade nachgesehen, ich habe den Code genauso drin und er funktioniert.
      Wichtig ist, dass du nur die Video-ID zwischen die Tags schreibst, etwa so: [youtube]KMU0tzLwhbE[/youtube]
      Hast du eventuell auch einen Zeilenumbruch nach dem embed/ drin? Der müsste dann raus 😉

      lg
      kill0rz

  2. Ronny says:

    Ja aber der Button im newpost oder postedit wird nicht angezeigt und lässt sich somit auch nicht anklicken .. das meinte ich damit. Hab aber alles genau so eingebaut .. und mehrmals überprüft.

Schreibe einen Kommentar zu kill0rz Antworten abbrechen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

Bitte löse die Rechnung! * Time limit is exhausted. Please reload CAPTCHA.